• RSS

[WP]さくらのSSL化プラグインでFatal errorが出る場合の対処法

  • このエントリーをはてなブックマークに追加
  • follow us in feedly

さくらサーバーでLet’s Encryptの無料SSLを利用しているWordPressで、さくらのレンタルサーバ 簡単SSL化プラグインを有効にしようとしたら「Fatal error」が表示される場合の対処法のご紹介です。

SAKURA RS WP SSLプラグインがFatal errorで有効化できない

SAKURA RS WP SSLプラグインをインストール後、「有効化」ボタンを押した際に、
「重大なエラーを引き起こしたため、プラグインを有効化できませんでした。
 Fatal error: Arrays are not allowed in class constants in *******/wp-content/plugins/sakura-rs-wp-ssl/modules/model/force-ssl.php on line 32
のエラーが発生する場合ですが、どうやらPHPのバージョンが5.6よりも古いことが原因ぽいです。

プラグインファイルに5.3や5.4のバージョンでは使えない変数が使われているようなので、SAKURA RS WP SSLプラグインを使うためには、さくらサーバーのコントロールパネルからPHPのバージョンを5.6以上にアップデートする必要があります。
さくらのSSL化プラグインでFatal errorが出る場合の対処法



  • このエントリーをはてなブックマークに追加
  • follow us in feedly

コメント

コメントを残す

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください