• RSS

[JS]IE下位バージョンでも透過画像を使えるようにするjQueryプラグイン「jquery.belatedPNG」

  • このエントリーをはてなブックマークに追加
  • follow us in feedly

以前にも紹介させていただいた DD_belatedPNG_0.0.8a.js ですが、

IE6、IE7 には対応していますがIE8 では動いてくれない…

ですので、がっつりIE下位バージョンに対応させようとなると、今回紹介させていただくjQueryベースのスクリプト jquery.belatedPNG.js を利用します。

jquery.belatedPNG のダウンロード

以下のページより jquery.belatedPNG をダウンロードします。


jquery.belatedPNG の設置

ダウンロードした jquery.belatedPNG.js を、jQueryファイルと一緒に <head> 内に設置します。
<!--[if lt IE 9]>
<script type="text/javascript" src="./jquery.belatedPNG.js"></script>
<script type="text/javascript">
(function($) {
$(function() {
$('.pngFix').fixPng();
});
})(jQuery);
</script>
<![endif]-->
あとは DD_belatedPNG_0.0.8a.js の時と同じように <img> タグに pngFix のクラスを指定します。



  • このエントリーをはてなブックマークに追加
  • follow us in feedly

コメント

コメントを残す